Welcome to the Birder's Diary Forum for Support And General Questions

Use the Support forum for all questions or issues.
Use the Wish List forum to leave your ideas for improving Birder’s Diary.

BUG: Date changes i...
 
Notifications
Clear all

[Solved] BUG: Date changes itself


Posts: 9
Topic starter
(@toddinsf)
Active Member
Joined: 9 months ago

I go into a record from 19__ (doesn't seem to matter which year, just last century).

I edit any field - doesn't even have to be the date.

Save.

Year is now changed to 20__.

Since 2091 is quite a long way from happening yet, & I would be well over 100 years old by then, I rather doubt I have need of entering records for that year just yet or probably ever. 😀

Reply
Topic Tags
10 Replies
1 Reply
(@toddinsf)
Joined: 9 months ago

Active Member
Posts: 9

Addendum: This happens even if I attempt to correct the date by editing it to 19__. It will still be 20__ after saving. The only work-around I've found is to create a new entry duplicating the info from the old one, then delete the old entry. I still cannot edit the new entry, however, or the same bug will wreck it.

Reply
Posts: 9
Topic starter
(@toddinsf)
Active Member
Joined: 9 months ago

More bugginess with year:

Now if I do a search through my records from (let's say) 1/1/1997 to 1/2/1997 it will instead display 1/1/1997 to 1/1/<the very last record in my database, which is currently 2091 due to this year bug>

Reply
Posts: 234
Admin
(@jeff)
Member
Joined: 10 months ago

Yikes Todd! Tell me about your computer please.

  1. What version of Windows?
  2. What hardware/maker of computer?
  3. What version of BD, include the Build # please?
  4. Have you ever tried editing before and it did NOT cause this problem? E.g. did this use to work fine?
  5. What is your language/region setting in Windows? E.g. For example, I am "English (US)".

It could be the setting for which century on your machine.

Windows 10

  • In the search box on the taskbar, type control panel, and then select Control Panel.
  • Under Clock, Language and Region, click Change date, time, or number formats
  • Click Regional and Language Options.
  • In the Region dialog box, click Additional settings.
  • Click the Date tab.
  • In the When a two-digit year is entered, interpret it as a year between box, change the upper limit for the century.
  • As you change the upper-limit year, the lower-limit year automatically changes.

Let me know what your settings are.

Let's start here and I am sure we can figure this out. Please be sure to answer all questions above.

Thanks,

Jeff

 

Reply
Posts: 9
Topic starter
(@toddinsf)
Active Member
Joined: 9 months ago

OK, wow, a bit overloaded on the volume of info needed here, lol.

Let me start from the bottom.

- Control Panel: ok.
- 'Clock, Languages, & Region': No, I only have 'Clock & Region'. Going with that.
- Change Date, etc. format: OK.
- Click Regional & Language options: There is no such thing to click. There is a 'Language Preferences'? Perhaps that?
- I got so lost here with the differences between what was listed & what my system showed that I couldn't even keep track. I finally found the century thing. I changed it up to 2200 (it had been at 2100).
- Went into BD & tried to edit one of the bugged entries back to the year it should be. It now has changed to 2191 from 2091.
- Point to consider: I NEVER type 2-digit years when making entry. I am trying '1-9-9-1'. I save, & I get (after this most recent change) '2191' showing on the entry.

After typing this, I set it down to 2000. Not only did this allow edits to enter dates correctly (at least in the 90s), but it also fixed the issue where a search from 27-10-91 to 28-10-91 was showing every single entry from 27-10-91 to forever.

Aaaand, now I can't even look at entries from 2000 onwards. The system reads 1-1-2000 to 31-12-2021 as 'oh, you want to look at 1-1-1900 to 31-12-1921? Sorry, no entries for that period'.

I've no idea why the edit system (both for editing changes & search parameters) is reading typed 4-digit year entries as 2-digit year entries, but clearly this is a bug.

  1. What version of Windows? 2010
  2. What hardware/maker of computer? Pieces & parts assembled by a friend. I've had it about 5 years now, never had a problem like this before.
  3. What version of BD, include the Build # please? V5.1 build 101
  4. Have you ever tried editing before and it did NOT cause this problem? E.g. did this use to work fine? Everything was fine until today. I have used BD for many, many years. I have never seen this happen before.
  5. What is your language/region setting in Windows? E.g. For example, I am "English (US)". English (US), although I do use dd/mm/yyyy format. Again, this has never caused a problem before.
Reply
Posts: 234
Admin
(@jeff)
Member
Joined: 10 months ago

Hi Todd,

So, something on your computer changed, but not Birder's Diary. None of this code has been touched as far as I can remember off the top of my head.

Did you install any software recently? When these sorts of things happen out of the blue, it can generally be attributed to recent installations, upgrades, changes.

I wonder if this same problem is affecting other software installed on your computer or only BD. For example, Excel or something else that has a date field on it.

Let me know. Signing off for tonight. But we can schedule a screen sharing session to dig deeper into this tomorrow if you have time.

Jeff

Reply
Posts: 9
Topic starter
(@toddinsf)
Active Member
Joined: 9 months ago

There is not a single new program on my computer. Not. One.

I have made no changes to settings on my computer before the one that was advised for me to try today. Not. One.

Reply
Posts: 234
Admin
(@jeff)
Member
Joined: 10 months ago

Hi Todd,

I can get onto your computer and have a look if you like.

Have you tried rebooting?

Do you remember what your original Century setting was before you changed it?

Let me know,

Jeff

Reply
Posts: 9
Topic starter
(@toddinsf)
Active Member
Joined: 9 months ago

Yes, I have rebooted. Multiple times.

Before I changed my century setting it was 2100 as max. It had been such for years; as stated, I only changed it after you advised to try that. I have since changed it back, with the results previously stated.

I have 10 hour shifts for the next 3 days. Earliest availability to coordinate is Saturday.

Reply
Posts: 234
Admin
(@jeff)
Member
Joined: 10 months ago

Ok Todd. Let's plan something for Saturday. I am on Central time. Let me know what time might work for you.

Instead of continuing to post here, please send email to support@BirdersDiary.com with a time that works for you.

Thanks,

Jeff

Reply
Posts: 234
Admin
(@jeff)
Member
Joined: 10 months ago

Update: Received email from Todd that the problem has been resolved.

He has always set his default date format to dd/mm/yyyy. But an apparent recent Microsoft Windows update changed this to dd/mm/yy. NOTE the 2 digit year. Once he reset that back to a 4-digit year format of yyyy (dd/mm/yyyy) everything is back working again.

So, if Windows updates your date format to a 2-digit year, you might expect this problem. And the solution is to change it back to a 4 digit year.

Thanks to Todd for figuring this out.

Jeff

Reply
Share: