Cinnamon Hummingbird

Welcome to the Birder's Diary Forum for Support And General Questions

Use the Support forum for all questions or issues.
Use the Wish List forum to leave your ideas for improving Birder’s Diary.
Setup your Forum photo and profile here.

Cloud downloading
 
Notifications
Clear all

[Solved] Cloud downloading

25 Posts
2 Users
1 Likes
100 Views
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Ok - I sent email David. I will call you at that time.

Reply
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Solved. David's Location on his Mobile device had "/" slashes in it. I did not take this into account when creating a meaningful import filename.

This has been fixed for all non-standard filename characters going forward.

Build 9 has the fix and is ready for installation.

Help | Internet: Check for a program update

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

Yes, that fixed it!

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

I have another checklist that does not download. The name has slashes, but you fixed that. It does not have quotes or apostrophe in the comments. I even deleted the comments and it still does not download.

Reply
Jeff
 Jeff
Admin
(@jeff)
Joined: 2 years ago

Creator & Technical Support
Posts: 625
Posted by: @magmatic

I have another checklist that does not download. The name has slashes, but you fixed that. It does not have quotes or apostrophe in the comments. I even deleted the comments and it still does not download.

Hi David,

Yep. This one is related to your "Comments with apostrophe" issue. In this case, you are probably submitting sightings with at least one name that contains an apostrophe; I was just able to reproduce this with an Outing containing "Nutting's Flycatcher".

Bad programming on my part. I should have taken all of this into account. My first time with PHP and MySQLI in the Web API is to blame.

I should have this fixed shortly. 

Stay tuned.

Reply
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Ok - this is fixed and tested against new code in the Web API. Please test by re-sending your Outings from BD Mobile that failed before. Reply back here and let me know.

Thx.

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

It does see the import, but imports 0 records. There are multiple records in the csv file.

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

However, after moving to build 10, it did download it OK.

Reply
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Hmmm. Interesting. Build 10 shouldn't have anything to do with this.

Please continue to test and let me know.

For my test, I did an example outing right here from my desk, and selected at least one name with an apostrophe in it ("Nutting's Flycatcher") and added an apostrophe to the comments. I had no problems with the download nor the import.

Although I did have to rebuild the Locations Performance table (View | Options | Special TAB) after the import of a new location. Fixed in next Build.

image

Let me know. 

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

I had not tried a name with an apostrophe. I have now and no comments. I still get the 0 records imported message. I tried both that and comments with an apostrophe and got the same error.

Having two apostrophes, like you did, makes no difference in my tests.

Reply
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

This isn't making sense David. I see your uploaded Outings in the Cloud and see that you have downloaded them. I have special test code that allows me to download your Outings. It downloads and imports without any problems.

So, let's schedule some time for me to get onto your computer. Are you available tomorrow, Friday, at some time?

Reply
Posts: 140
Topic starter
(@magmatic)
Estimable Member
Joined: 2 years ago

As I said in another stream, I am not getting the 0 records now.

Reply
Jeff
Posts: 625
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Ok David. Please try the end-to-end test suggested in one of your other posts and let us know if all is working now.

Reply
Page 2 / 2
Share: