Cinnamon Hummingbird

Welcome to the Birder's Diary Forum for Support And General Questions

Use the Support forum for all questions or issues.
Use the Wish List forum to leave your ideas for improving Birder’s Diary.
Setup your Forum photo and profile here.

Run-time error 3346
 
Notifications
Clear all

[Solved] Run-time error 3346

18 Posts
2 Users
2 Likes
288 Views
Jeff
Posts: 659
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Hi Scott,

Ok - that definitely helps a lot. I needed the steps to reproduce. 

As for the uploads, you must ZIP/compress all files and then ONLY upload the ZIP file using the "Support >> File Upload" page on this site. That should work without any issues.

Now, I see what the problem is. Your database is marked as V5.3.19. So, I am assuming at some point that you upgraded to v5.3.19, ran it, but went back to using v5.2. When you run v5.3.19 it upgrades your database to the new format. V5.2 is complaining because one of the tables it expects in an older format has changed.

When you install v5.3.19, it creates a copy of your v5.2 database... C:\Birder's Diary\data\database-preInstall.mdb.

If you have not run any other installations since, then this file will still be your old v5.2 database. However, if you have modified your data in any way (e.g. added sightings, etc), now that older database is out of sync.

You can rename "\data\database.mdb" to "\data\database-v5319.mdb", and then rename "\data\database-preInstall.mdb" to "\data\database.mdb" and attempt to run v5.2. BD looks for and opens "\data\databsae.mdb" when it starts. If this works you are back in business, but perhaps your data is now out of sync and you have lost any changes you made.

Probably easier to just go ahead and upgrade to v5.3. I tested your database against v5.3 and it works fine with reporting.

Let me know how I can help.

Reply
Posts: 10
Topic starter
(@redwren)
Active Member
Joined: 7 months ago

I reverted to the previous version as I can’t locate my password/license.

At least we know what went wrong.

Reply
Jeff
 Jeff
Admin
(@jeff)
Joined: 2 years ago

Creator & Technical Support
Posts: 659
Posted by: @redwren

I reverted to the previous version as I can’t locate my password/license.

At least we know what went wrong.

I responded to your email about your Online Store account. Let me know if I can help further and please update us that all is good at v5.3.

Thanks. 

Reply
Posts: 10
Topic starter
(@redwren)
Active Member
Joined: 7 months ago

Thanks for all your help Jeff!

Reply
Jeff
Posts: 659
 Jeff
Admin
(@jeff)
Creator & Technical Support
Joined: 2 years ago

Update: After installing v5.3.x all is up and running correctly.

Reply
Page 2 / 2
Share: